Reduced network speeds
Incident Report for File Sanctuary
Resolved
Things have been stable for several hours, this issue has been resolved.
Posted Aug 19, 2020 - 10:37 BST
Monitoring
A majority of ISPs and datacentre operators using LINX at Harbour Exchange have now been able to restore service and most of the congestion has now cleared. Some work is still ongoing for so there may be occasional blips over the next few hours, but we will continue to monitor the situation overnight.
Posted Aug 18, 2020 - 22:30 BST
Identified
We are aware of an issue that is causing reduced network speeds, this is due to a power failure this morning at the Harbour Exchange datacentre in London Docklands. This datacentre is a major location for the London Internet Exchange (LINX) which is used by most major UK ISPs and datacentre operators to pass traffic between networks, so is causing widespread problems on the UK's internet right now. You can read more about the issue here.

When the problem first occurred, traffic was rerouted via alternate paths however these alternate paths have become increasingly congested as more and more ISPs are routing around the issues. Power has been restored to our network equipment in Harbour Exchange and so we are slowly increasing the amount of traffic routing back via that location, however many ISPs in the datacentre still don't have their equipment back up and running at this time, and due to COVID-19 there is a strict limit on how many ISPs are being allowed to send their staff on-site to restore service to their equipment at any one time. This means that total network capacity in that location is still limited, forcing us to continue to use alternate routes at this time.

As more ISPs are able to restore service, capacity will gradually increase in Harbour Exchange and we can increase the traffic that we send via that site, causing speeds to increase once again, however we have been advised that it could be several more hours until everything is back to normal.

No File Sanctuary services have experienced outages as a result of this issue. Web and email traffic continue to work fine, however large file transfers may take considerably longer at this time. We will provide an update once the issue is resolved.
Posted Aug 18, 2020 - 17:30 BST
This incident affected: Cloud Servers, Web and Email Hosting, and Customer Portal.