Increased latency to Coventry datacenter
Incident Report for File Sanctuary
Resolved
Traffic has been running normally for an extended period of time now, so we're marking this issue as resolved.
Posted Apr 16, 2020 - 16:37 BST
Monitoring
The latency issue has been resolved and traffic is flowing normally again. We will continue to monitor the situation.
Posted Apr 16, 2020 - 14:09 BST
Investigating
We are currently investigating an increase in latency to our Coventry datacenter. All services remain online and operational.

Services hosted in our other datacenters are unaffected.
Posted Apr 16, 2020 - 13:28 BST
This incident affected: Cloud Servers, Web and Email Hosting, and Customer Portal.