Intermittent broadband connectivity

Incident Report for File Sanctuary

Resolved

We have seen stability remain overnight, so are marking this issue as resolved.
Posted Nov 05, 2025 - 11:31 GMT

Monitoring

Packet loss levels have improved, but we are continuing to monitor the situation.
Posted Nov 04, 2025 - 22:22 GMT

Investigating

We are currently investigating high levels of packet loss for some broadband lines. We apologise for the disruption and are working towards a resolution as a matter of urgency.
Posted Nov 04, 2025 - 21:13 GMT
This incident affected: Broadband.