Power issue at Coventry datacentre
Incident Report for File Sanctuary
Resolved
The electricians have completed their repairs and have left site. Normal mains power has been restored and is stable. This incident has been resolved.
Posted Jul 18, 2020 - 21:42 BST
Update
Our Coventry datacentre is currently still running on diesel generator backup power, so is still considered to be at-risk at this time. Electricians and Western Power are still on-site and are working to resolve the root cause of the fault. We will provide updates as necessary.
Posted Jul 18, 2020 - 20:44 BST
Monitoring
Power has now been restored and affected Cloud Servers are now back online. We're continuing to monitor the situation closely.
Posted Jul 18, 2020 - 20:04 BST
Identified
There has been a further power failure at our Coventry datacentre. Electricians and Western Power are currently on site and are working to rectify the issue.
Posted Jul 18, 2020 - 19:50 BST
Monitoring
All affected Cloud Servers are now back online. We're continuing to monitor the situation closely.
Posted Jul 18, 2020 - 16:49 BST
Investigating
We are currently investigating a power interruption to our Coventry datacentre. Power appears to have already been restored, and servers are coming back online.
Posted Jul 18, 2020 - 16:30 BST
This incident affected: Cloud Servers, Web and Email Hosting, and Customer Portal.